antispamsniper.com Forum Index antispamsniper.com
The reliable anti-spam protection
 
 FAQFAQ   SearchSearch     ProfileProfile   Log inLog in   RegisterRegister 

Gmail accounts are not checked for spam

 
Post new topic   Reply to topic    antispamsniper.com Forum Index -> AntispamSniper for TheBat!
View previous topic :: View next topic  
Author Message
glomme



Joined: 10 Apr 2018
Posts: 6
Location: Huntsville

PostPosted: Thu May 23, 2019 6:39 am    Post subject: Gmail accounts are not checked for spam Reply with quote

When I try to check Gmail accounts for spam this does not work. New emails do not appear in the logfile. If I try to do this with a GMX account it works fine. Since I use two factor authentication, I also have an app password stored in the account of Antispamsniper. But no matter if I enter the POP3 server of Gmail or the Imap server it just doesn't work. Also my Gmail accounts are not automatically added in contrast to my GMX account (example).

What can I do to make this work with Gmail?

Many thanks in advance for the answers
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 680

PostPosted: Thu May 23, 2019 9:37 am    Post subject: Reply with quote

By default SSL filtering is disabled. It is possible to enable the filtering on Accounts tab in plug-in settings. Also it is necessary to import the plug-in root certificate to TheBat as described here:
http://antispamsniper.com/forum/viewtopic.php?t=700
Back to top
View user's profile Send private message Send e-mail
glomme



Joined: 10 Apr 2018
Posts: 6
Location: Huntsville

PostPosted: Thu May 23, 2019 10:39 am    Post subject: Still don't work Reply with quote

vetaltm wrote:
By default SSL filtering is disabled. It is possible to enable the filtering on Accounts tab in plug-in settings. Also it is necessary to import the plug-in root certificate to TheBat as described here:
http://antispamsniper.com/forum/viewtopic.php?t=700


I did it exactly like in the topic you posted.
Imported the certificate into the addressbook and made sure that TheBat user internal SSL:




But with the same result. Gmail Emails still not shown in the logfile.
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 680

PostPosted: Thu May 23, 2019 10:49 am    Post subject: Reply with quote

It is necessary to enable the checkboxes in plug-in settings:
Back to top
View user's profile Send private message Send e-mail
glomme



Joined: 10 Apr 2018
Posts: 6
Location: Huntsville

PostPosted: Thu May 23, 2019 10:59 am    Post subject: Here the seeting Reply with quote

That's exactly like it looks like at me.
Also after import the certificate and check the settings I deleted the gemail account created a new gmail app password and added the account again. Same result after sending me a test message to this account.
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 680

PostPosted: Thu May 23, 2019 11:23 am    Post subject: Reply with quote

The new accounts are added to list automatically. It is needed only for filtering spam by headers and for filtering IMAP. For generic POP3 accounts the plug-in classifies new mail upon receiving, and adds records about each message to Filtering log.
Back to top
View user's profile Send private message Send e-mail
glomme



Joined: 10 Apr 2018
Posts: 6
Location: Huntsville

PostPosted: Thu May 23, 2019 5:41 pm    Post subject: Nathing added... Reply with quote

Hello,

Deleted all manual added gmail accounts, received test email in my gmail accounts (12:31) but nothing is automatic added nor shown up in the logfiile.



Looked up the TB logfiles that what it say:

Code:
 23.05.2019, 12:26:52: IMAP  - Verbinde zum IMAP-Server imap.gmail.com auf Port 993
 23.05.2019, 12:26:52: IMAP  - Einleitung TLS-Handshake
>23.05.2019, 12:26:52: IMAP  - Zertifikat S/N: 64, Algorithmus: RSA (512 Bits), ausgestellt von 23.05.2019 09:49:31 bis 18.05.2039 09:49:31, für 1 Host(s): imap.gmail.com.
>23.05.2019, 12:26:52: IMAP  - Besitzer: "US", "California", "Mountain View", "Google LLC", "imap.gmail.com".
>23.05.2019, 12:26:52: IMAP  - Root: "EN", "root.antispamsniper.com" Gültig ab 18.11.2008 06:09:41 bis 13.11.2028 06:09:41.
 23.05.2019, 12:26:52: IMAP  - TLS-Handshake vollständig
 23.05.2019, 12:26:52: IMAP  - Verbunden mit IMAP-Server (imap.gmail.com)
>23.05.2019, 12:26:52: IMAP  - Gimap ready for requests from 136.xxx.xxx.xxx x14mb19435603ybq
 23.05.2019, 12:26:52: IMAP  - Authentifiziere (Benutzer: "h.xxx@gmail.com", Methode: "XOAUTH2")...


1st line connecting to Gmail, in the 5th line also can see the antispamsniper certificate.

Maybe Antispamsniper has a problem with XOAUTH2?

I looked at my ionos and gms accounts and they use as method "Login" instead of XOAUTH2.


Last edited by glomme on Thu May 23, 2019 5:57 pm; edited 3 times in total
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 680

PostPosted: Thu May 23, 2019 5:50 pm    Post subject: Reply with quote

If you are using IMAP, check the port in account settings. The default IMAP ports are 143 and 993. The accounts with non-standard ports are not added automatically.
Back to top
View user's profile Send private message Send e-mail
glomme



Joined: 10 Apr 2018
Posts: 6
Location: Huntsville

PostPosted: Thu May 23, 2019 5:59 pm    Post subject: Reply with quote

The ports are standard:

Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 680

PostPosted: Thu May 23, 2019 6:12 pm    Post subject: Reply with quote

Please try switching to standard authentication.
Back to top
View user's profile Send private message Send e-mail
glomme



Joined: 10 Apr 2018
Posts: 6
Location: Huntsville

PostPosted: Thu May 23, 2019 6:33 pm    Post subject: Reply with quote

I tried to deactivate it but also if I reduce my security (2factor) in gmail and allow less secure apps it change nothing. Also switched in the bat from Oauth (what is standard in thebat) to Standard I still see in the Thebat logs that there is standing Method : XOAUTH2.

So from my end I guess I can's switch it off.
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 680

PostPosted: Thu May 23, 2019 7:23 pm    Post subject: Reply with quote

It is necessary to switch the authentication in TheBat to standard. If it doesn't work, please contact Ritlabs with this issue.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    antispamsniper.com Forum Index -> AntispamSniper for TheBat! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group