antispamsniper.com Forum Index antispamsniper.com
The reliable anti-spam protection
 
 FAQFAQ   SearchSearch     ProfileProfile   Log inLog in   RegisterRegister 

Antispamsniper 3.3.4.3 doesn't install

 
Post new topic   Reply to topic    antispamsniper.com Forum Index -> AntispamSniper for TheBat!
View previous topic :: View next topic  
Author Message
erikb



Joined: 01 Dec 2019
Posts: 4
Location: northern California

PostPosted: Sun Dec 01, 2019 9:07 pm    Post subject: Antispamsniper 3.3.4.3 doesn't install Reply with quote

I'm trying to install the latest version of Antispamsniper, but I keep getting errors (I see someone else has posted today with the same problem).

When I click Add to add the 3.3.4.3, I get the error message "Could not install the plug-in. It either has some internal problem or it cannot be qualified as a plug-in".

I'm running 64-bit Voyager, but I've tried both the 32-bit and 64-bit versions of Antispamsniper, with no luck. I've tried copying and moving folders, and I've checked permissions of the folder and of the plug-in. I've tried installing both the free and paid versions (I've had a paid license since 2007). Nothing works. It's driving me nuts. I've uninstalled the previous version of Antispamsniper, so I've lost my old database and settings.

I'm using Voyager 8.6.0.4 on Win 10.

What's wrong?
_________________
Using The Bat since 2003
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 687

PostPosted: Sun Dec 01, 2019 9:49 pm    Post subject: Reply with quote

Try to update Voyager to more recent build. It may be an issue with this specific version, because there were no changes in plug-in itself and installer able to raise this kind of error. Here is a previous version of the plug-in for test:
http://antispamsniper.com/forum/viewtopic.php?t=778
Back to top
View user's profile Send private message Send e-mail
erikb



Joined: 01 Dec 2019
Posts: 4
Location: northern California

PostPosted: Sun Dec 01, 2019 10:32 pm    Post subject: Reply with quote

I'm afraid that this antispamsniper version gives the same error.

I've updated Voyager to the latest version (8.8.9.11), but it didn't help.

Here's something that might be a clue. The Bat Professional 8.6.0.4 does not get an error with either of the antispamsniper versions, however it does not seem to install antispamsniper correctly. The Bat Professional appears to be looking for the directory C:\Program Files\The Bat!\MAIL\AntispamSniper, but that MAIL directory does not exist. The mail is actually being stored in %APPDATA%\Roaming\The Bat! Pwd.

I'm only using The Bat Professional as a test. I use Voyager for my email. That's the one I need to get working.

I've spent far too much time on this today. I have to get it working, but I'm running out of time. I hope we can get it working. What can you suggest?
_________________
Using The Bat since 2003
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 687

PostPosted: Sun Dec 01, 2019 10:49 pm    Post subject: Reply with quote

Actually it is Voyager gives error, the plug-in is not even loaded. This is why it is hard to analyze the issue. Make sure that the plug-in is installed on the same drive with Voyager, the installation folder has correct permissions, and the installed plug-in is 64-bit as Voyager.
TheBat is looking for a wrong folder because when the plug-in is installed to integrate with Voyager, it uses a relative path to configuration folder instead of absolute paths with TheBat. This mode is specified during installation by selecting "Voyager support" option. The file antispamsniper.dir in the plug-in installation folder controls this behavior. It is possible to delete this file to make the plug-in work correctly with TheBat.
Back to top
View user's profile Send private message Send e-mail
erikb



Joined: 01 Dec 2019
Posts: 4
Location: northern California

PostPosted: Mon Dec 02, 2019 12:04 am    Post subject: Reply with quote

I don't think that was the problem with The Bat Professional. Each time I tested The Bat Professional, I was uninstalling the Voyager version and doing a fresh install without enabling the Voyager option.

However I'm not concerned with The Bat Professional. I need to get Antispamsniper working with Voyager. I uninstalled Antispamsniper, then rebooted my system, and then installed and tested first the 32 bit version and then the 64 bit version. Both give me the same error.

I'm installing Antispamsniper exactly the way I installed the old version. It's in the root directory of my X: drive (a USB stick), at the same level as my Voyager directory. Everything looks correct. There's an AntispamSniper directory in Voyager\Mail, just as there was in the old Antispamsniper version, with similar contents. I'm at my wits end on this. I need to get it working, but at this point I don't know what to do next.
_________________
Using The Bat since 2003
Back to top
View user's profile Send private message
erikb



Joined: 01 Dec 2019
Posts: 4
Location: northern California

PostPosted: Tue Dec 03, 2019 4:08 pm    Post subject: Reply with quote

In case this helps someone, I finally got AntispamSniper working on Voyager, but I don't know why it worked. I did everything the same as I did before, but this time it worked.

You need to use the 32-bit version of AntispamSniper with Voyager, even if you're using 64-bit The Bat Professional. I've been testing with both the 32-bit and 64-bit versions of AntispamSniper, but until today neither worked. When it finally worked today, it was with the 32-bit version of AntispamSniper.
_________________
Using The Bat since 2003
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    antispamsniper.com Forum Index -> AntispamSniper for TheBat! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group