antispamsniper.com Forum Index antispamsniper.com
The reliable anti-spam protection
 
 FAQFAQ   SearchSearch     ProfileProfile   Log inLog in   RegisterRegister 

Multiple Instances of Outlook

 
Post new topic   Reply to topic    antispamsniper.com Forum Index -> AntispamSniper for Outlook
View previous topic :: View next topic  
Author Message
cpriest



Joined: 01 Jul 2012
Posts: 28

PostPosted: Wed Jul 11, 2012 2:48 am    Post subject: Multiple Instances of Outlook Reply with quote

Well this has been a long, hard road but I think I'm almost there. I have two copies successfully running and loaded into two separate outlook instances. Here is how I did it:

1. Two copies of the .dll, each one edited to use a different settings directory (edited the string resource)
* One of these copies has had all three UUID's changed (to newly generated uuids). This was done for all string references and all binary references. I found numerous binary references that were in strange orders but they were all consistent.
2. A registry modification is done via a shortcut just prior to launch that "enables one copy and disables the other" via the Load settings in the registry, causing the launching process to only load one of the copies.
The other launch shortcut does the same thing but in reverse (loads the second copy).

This all works fine. I get two different instances of AntispamSniper loaded, one into each outlook instance. They each have their own settings and run independently.

The problem is, when I launch the second instance, the first one will go haywire. Things start slowing down only for the first instance, and given enough time the two folder references (junk/unsure) are either blank or reset back to their original (Junk Email / Unsure (...)).

So... something tells me that the software is doing something that is crossing the application boundaries, like a FindWindow or some other non-instance-aware routine.

Can you help me?
Back to top
View user's profile Send private message
sandrela



Joined: 28 Jan 2014
Posts: 1

PostPosted: Wed Jan 29, 2014 4:22 am    Post subject: Reply with quote

I guess you are trying to load the plug-in to the second instance of Outlook. I explained the issue by mail.
_________________
Prep4sure.com - comptia 220-901 certification exam questions and sample training for certificate and test
Back to top
View user's profile Send private message
cpriest



Joined: 01 Jul 2012
Posts: 28

PostPosted: Thu Jan 30, 2014 12:36 pm    Post subject: Reply with quote

Yeah, I gave up on it long, long ago.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    antispamsniper.com Forum Index -> AntispamSniper for Outlook All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group