antispamsniper.com Forum Index antispamsniper.com
The reliable anti-spam protection
 
 FAQFAQ   SearchSearch     ProfileProfile   Log inLog in   RegisterRegister 

"mark as spam" is very very slow
Goto page Previous  1, 2, 3  Next
 
Post new topic   Reply to topic    antispamsniper.com Forum Index -> AntispamSniper for TheBat!
View previous topic :: View next topic  
Author Message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 657

PostPosted: Wed Jun 20, 2012 9:50 pm    Post subject: Reply with quote

For IMAP the performance mostly depends on the speed of your server and communication channel. Try to check "Mark as spam" for some POP3 account or simply mark as spam one of the messages in Junk mail folder. If it works faster, apparently the issue cannot be fixed by changing plug-in data. Try to disable the option "Move messages marked as Junk to the Junk folder" on Anti-spam tab in TheBat preferences. In this case the messages marked as Junk are not moved, i.e. TheBat doesn't send the appropriate IMAP commands to server and doesn't wait for the response.
Back to top
View user's profile Send private message Send e-mail
revelli



Joined: 15 May 2007
Posts: 92

PostPosted: Wed Jun 20, 2012 10:11 pm    Post subject: Reply with quote

Ok I think we have found the solution... I tried with a pop3 account and it's very fast. Gmail imap servers should be slow...

Anyway I have a problem. I unselected the "Move messages marked as Junk to the Junk folder" option but even if unselect, it always move message to the Junk folder.... Sad

I tried to relaunch The Bat. Any idea?
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 657

PostPosted: Wed Jun 20, 2012 10:33 pm    Post subject: Reply with quote

The latest version of the plug-in doesn't use this option. It works for AntispamSniper 3.2.7.1:
http://antispamsniper.com/download/sniper-mui.exe
Back to top
View user's profile Send private message Send e-mail
revelli



Joined: 15 May 2007
Posts: 92

PostPosted: Wed Jun 20, 2012 10:40 pm    Post subject: Reply with quote

Ok I installed it. And it's very fast if I uncheck this option but also even if I check it.

So I suppose that the problem comes from your last version of the plugin 3.3.1.1

Because this old version works fine even if messages are moved to the junk folder.

BTW, it's a problem to use this old version? What change?
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 657

PostPosted: Wed Jun 20, 2012 10:51 pm    Post subject: Reply with quote

Please try the latest build:
http://antispamsniper.com/dl/3.0/sniper-mui-3.3.1.3.exe

Versions 3.3.x use TheBat API for moving the messages to Junk folder. If the latest build works like 3.3.1.1, the issue is on TheBat side and I'll contact Ritlabs for resolution.
Back to top
View user's profile Send private message Send e-mail
revelli



Joined: 15 May 2007
Posts: 92

PostPosted: Wed Jun 20, 2012 10:54 pm    Post subject: Reply with quote

Exactly the same unfortunately. I prefer to use the old one...

What is going to change with the old one?
Back to top
View user's profile Send private message
revelli



Joined: 15 May 2007
Posts: 92

PostPosted: Wed Jun 20, 2012 10:59 pm    Post subject: Reply with quote

BTW I have another question. Your plugin detects automatically a lot of accounts for each gmail account.

The mail detected it's the same but I have a lot of account for each mail account because I suppose it detects different gmail servers like we-in-f108.1e100.net or similar

Is this is a problem or not? I remember that in the past you suggested me to force something writing gmail ports within a windows file. This is still useful or it's not a problem to have all these accounts detected?
Back to top
View user's profile Send private message
revelli



Joined: 15 May 2007
Posts: 92

PostPosted: Wed Jun 20, 2012 11:17 pm    Post subject: Reply with quote

I have just noticed that with the old plugin I don't have a very annoying bug I was having before and that I thought it was caused by The Bat.

The bug what that very often on the right panel of the Bat messages become with no reason unselected.

It was very annoying to select them manually. I don't have it anymore
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 657

PostPosted: Wed Jun 20, 2012 11:59 pm    Post subject: Reply with quote

Please try another build of the latest version:
http://antispamsniper.com/dl/3.0/sniper-mui-3.3.1.4.exe

It must work faster.
Back to top
View user's profile Send private message Send e-mail
revelli



Joined: 15 May 2007
Posts: 92

PostPosted: Thu Jun 21, 2012 12:01 am    Post subject: Reply with quote

Yes thanks a lot! It works
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 657

PostPosted: Thu Jun 21, 2012 12:03 am    Post subject: Reply with quote

revelli wrote:
BTW I have another question. Your plugin detects automatically a lot of accounts for each gmail account.

The mail detected it's the same but I have a lot of account for each mail account because I suppose it detects different gmail servers like we-in-f108.1e100.net or similar

Is this is a problem or not? I remember that in the past you suggested me to force something writing gmail ports within a windows file. This is still useful or it's not a problem to have all these accounts detected?

Delete all duplicated accounts, then specify imap.gmail.com as server name on IMAP tab of the account properties in plug-in. The problem occurs because *.gmail.com names resolve to different IP addresses, which cannot be resolved back to the correct domain name. The plug-in knows only IP address, so in this case it is necessary to help by specifying the correct domain name in account settings.
Back to top
View user's profile Send private message Send e-mail
revelli



Joined: 15 May 2007
Posts: 92

PostPosted: Thu Jun 21, 2012 1:53 pm    Post subject: Reply with quote

Hi the problem I have now is that since the various install we did yesterday, now the plugin doesn't classify anything anymore.

The last mail classified was yesterday evening during one of our install.

I can mark mail as spam and they are moved to the JUNK MAIL folder

But incoming mail is no more classified by plugin and spam is not moved to the JUNK folder
Back to top
View user's profile Send private message
revelli



Joined: 15 May 2007
Posts: 92

PostPosted: Thu Jun 21, 2012 1:56 pm    Post subject: Reply with quote

If I go to the log I see that something is blocking the classifying process.

The first log is:

"Testing: classified as ham" on the status field

It last for hours

Even if I delete log or mail it do the same with next mail it tries to classify
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 657

PostPosted: Thu Jun 21, 2012 3:42 pm    Post subject: Reply with quote

revelli wrote:
If I go to the log I see that something is blocking the classifying process.

The first log is:

"Testing: classified as ham" on the status field

It last for hours

Even if I delete log or mail it do the same with next mail it tries to classify

Does the plug-in classify mail, with status above or something else? Let me see the contents of Filtering log (top 100-200 lines). Please send it to support@antispamsniper.com.
Back to top
View user's profile Send private message Send e-mail
vetaltm
Author


Joined: 05 Feb 2006
Posts: 657

PostPosted: Thu Jun 21, 2012 3:44 pm    Post subject: Reply with quote

vetaltm wrote:
revelli wrote:
If I go to the log I see that something is blocking the classifying process.

The first log is:

"Testing: classified as ham" on the status field

It last for hours

Even if I delete log or mail it do the same with next mail it tries to classify

Does the plug-in classify mail, with status above or something else? Let me see the contents of Filtering log (top 100-200 lines). Please send it to support@antispamsniper.com.

Also check that all checkboxes are enabled on Accounts tab, and IMAP accounts are added automatically.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Post new topic   Reply to topic    antispamsniper.com Forum Index -> AntispamSniper for TheBat! All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group