antispamsniper.com Forum Index antispamsniper.com
The reliable anti-spam protection
 
 FAQFAQ   SearchSearch     ProfileProfile   Log inLog in   RegisterRegister 

Runtime error - unusual termination

 
Post new topic   Reply to topic    antispamsniper.com Forum Index -> AntispamSniper for TheBat!
View previous topic :: View next topic  
Author Message
jwsherman



Joined: 20 Aug 2006
Posts: 5

PostPosted: Thu Oct 05, 2006 8:13 pm    Post subject: Runtime error - unusual termination Reply with quote

Running Antispamsniper 1.6.7.3 on The Bat 3.85.03, whenever I try to mark a message or group of messages as spam, I receive the following error:

---------------------------
Microsoft Visual C++ Runtime Library
---------------------------
Runtime Error!

Program: C:\Program Files\The Bat!\thebat.exe


This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

---------------------------
OK
---------------------------

I've been running this same configuration (with upgrades to the software) for months now, and this is the first time this has happened.

This doesn't happen when The Bat is running by itself - when I mark a message as spam without Antispamsniper loaded, an alert appears that no learning software is present, the message is moved to the common junk folder, and all continues without trouble.

I love this software, please help.

Thank you,
JW Sherman
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 651

PostPosted: Fri Oct 06, 2006 1:19 am    Post subject: Re: Runtime error - unusual termination Reply with quote

jwsherman wrote:
Runtime Error!

It looks like the classification database is broken. It happens sometimes after unexpected shutdowns of TheBat during training the plug-in (e.g. killing the process from Task Manager or turning off the power). BTW, the plug-in displays a "learning" icon during updating the database.

Cleaning the classification database and training the plug-in again can fix this bug and remove the errors. Go to configuration window, press Options | "Clear database" button. The classification database will be replaced with the pre-trained files, but the other settings will remain unchanged.

The future versions will be less vulnerable to various crashes and unexpected shutdowns. But with the current build it is good idea to backup periodically the configuration files from the base directory (see the path to this folder in Options | "Base directory" field).
Back to top
View user's profile Send private message Send e-mail
jwsherman



Joined: 20 Aug 2006
Posts: 5

PostPosted: Fri Oct 06, 2006 2:54 pm    Post subject: Reply with quote

Quote:
Cleaning the classification database and training the plug-in again can fix this bug and remove the errors. Go to configuration window, press Options | "Clear database" button. The classification database will be replaced with the pre-trained files, but the other settings will remain unchanged.

Yep, this fixed it. Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    antispamsniper.com Forum Index -> AntispamSniper for TheBat! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group