antispamsniper.com Forum Index antispamsniper.com
The reliable anti-spam protection
 
 FAQFAQ   SearchSearch     ProfileProfile   Log inLog in   RegisterRegister 

TLS handshake failure with antispamSniper v3.3.1.5

 
Post new topic   Reply to topic    antispamsniper.com Forum Index -> AntispamSniper for TheBat!
View previous topic :: View next topic  
Author Message
YU_aZAw3



Joined: 27 Feb 2014
Posts: 7

PostPosted: Thu Feb 27, 2014 4:48 pm    Post subject: TLS handshake failure with antispamSniper v3.3.1.5 Reply with quote

i installed antispamSniper 3.3.1.5 for TheBat! yesterday. its a registered version.

i noticed none of my email accounts would work due to a TLS error as follows:

Code:

2/27/2014, 08:15:58: FETCH - TLS handshake failure. Invalid server certificate. The certificate or one of the certificates in the certificate chain does not have a valid signature.. The certificate or certificate chain is based on an untrusted root.


removed antispamSniper from TheBat! and mail TLS handshake works again.

is there a config setting i didn't set so TLS isn't failed when using antispamSniper?
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 651

PostPosted: Thu Feb 27, 2014 5:18 pm    Post subject: Reply with quote

To solve the issue see the instructions how to add root SSL certificate to TheBat:
http://antispamsniper.com/forum/viewtopic.php?t=504

Also it is possible to turn off filtering SSL in plug-in settings on Accounts tab.
Back to top
View user's profile Send private message Send e-mail
YU_aZAw3



Joined: 27 Feb 2014
Posts: 7

PostPosted: Fri Feb 28, 2014 9:46 pm    Post subject: Reply with quote

vetaltm wrote:
To solve the issue see the instructions how to add root SSL certificate to TheBat:
http://antispamsniper.com/forum/viewtopic.php?t=504

Also it is possible to turn off filtering SSL in plug-in settings on Accounts tab.


adding the root cer didn't stop the error message.

i do see where i can turn off the "Filter SSL protected connections". does that equate to Antispamsniper not blocking incoming email via SSL connection?
Back to top
View user's profile Send private message
rbender



Joined: 28 Oct 2014
Posts: 1

PostPosted: Tue Oct 28, 2014 8:23 pm    Post subject: TLS handshake failure Reply with quote

Hi,

Yesterday I buy and installed the registered version 3.3.1.5.

And now I have the same problem (TLS handshake failure) with one account from arcor.

Installing SSL certificate to TheBat also does not help.

Turn off filtering SSL connections does work, but should this really be done?

How did you solve the problem?
Back to top
View user's profile Send private message
vetaltm
Author


Joined: 05 Feb 2006
Posts: 651

PostPosted: Tue Oct 28, 2014 11:54 pm    Post subject: Re: TLS handshake failure Reply with quote

rbender wrote:
Turn off filtering SSL connections does work, but should this really be done?

When filtering SSL is disabled in plug-in, it doesn't do anything with SSL protocol. In this case most probably there is a problem with the server certificate.
Back to top
View user's profile Send private message Send e-mail
micharc



Joined: 22 Nov 2014
Posts: 1

PostPosted: Sat Nov 22, 2014 6:09 pm    Post subject: Re: TLS handshake failure with antispamSniper v3.3.1.5 Reply with quote

YU_aZAw3 wrote:
i installed antispamSniper 3.3.1.5 for TheBat! yesterday. its a registered version.

i noticed none of my email accounts would work due to a TLS error as follows:

Code:

2/27/2014, 08:15:58: FETCH - TLS handshake failure. Invalid server certificate. The certificate or one of the certificates in the certificate chain does not have a valid signature.. The certificate or certificate chain is based on an untrusted root.


removed antispamSniper from TheBat! and mail TLS handshake works again.

is there a config setting i didn't set so TLS isn't failed when using antispamSniper?


AntispamSniper for The Bat - v3.3.1.5
The Bat - v6.0.99
Win8.1

In my case SSL filtering works ok if The Bat is configured for using internal implementation of SSL certificate storage only (Options - S/MIME and TLS - Internal implementation) and Antispamsnippers SSL certificate is imported into The Bat address book.

But SSL filtering doesn't work with option 'Options - S/MIME and TLS - Microsoft CriptoAPI' in spite of imported Antispamsnippers SSL certificate (IExplorer - Options - Content - SSL - Import certificate).

Check your options tab.
Back to top
View user's profile Send private message
YU_aZAw3



Joined: 27 Feb 2014
Posts: 7

PostPosted: Fri Nov 20, 2015 12:02 am    Post subject: Re: TLS handshake failure Reply with quote

rbender wrote:
Hi,

Yesterday I buy and installed the registered version 3.3.1.5.

And now I have the same problem (TLS handshake failure) with one account from arcor.

Installing SSL certificate to TheBat also does not help.

Turn off filtering SSL connections does work, but should this really be done?

How did you solve the problem?


i tried again today and i've not been able solve the problem.
Back to top
View user's profile Send private message
YU_aZAw3



Joined: 27 Feb 2014
Posts: 7

PostPosted: Fri Nov 20, 2015 12:03 am    Post subject: Re: TLS handshake failure Reply with quote

vetaltm wrote:
rbender wrote:
Turn off filtering SSL connections does work, but should this really be done?

When filtering SSL is disabled in plug-in, it doesn't do anything with SSL protocol. In this case most probably there is a problem with the server certificate.


that's the error msg i'm getting, that the cert is invlaid
Back to top
View user's profile Send private message
YU_aZAw3



Joined: 27 Feb 2014
Posts: 7

PostPosted: Fri Nov 20, 2015 12:05 am    Post subject: Re: TLS handshake failure with antispamSniper v3.3.1.5 Reply with quote

micharc wrote:
YU_aZAw3 wrote:
i installed antispamSniper 3.3.1.5 for TheBat! yesterday. its a registered version.

i noticed none of my email accounts would work due to a TLS error as follows:

Code:

2/27/2014, 08:15:58: FETCH - TLS handshake failure. Invalid server certificate. The certificate or one of the certificates in the certificate chain does not have a valid signature.. The certificate or certificate chain is based on an untrusted root.


removed antispamSniper from TheBat! and mail TLS handshake works again.

is there a config setting i didn't set so TLS isn't failed when using antispamSniper?


AntispamSniper for The Bat - v3.3.1.5
The Bat - v6.0.99
Win8.1

In my case SSL filtering works ok if The Bat is configured for using internal implementation of SSL certificate storage only (Options - S/MIME and TLS - Internal implementation) and Antispamsnippers SSL certificate is imported into The Bat address book.

But SSL filtering doesn't work with option 'Options - S/MIME and TLS - Microsoft CriptoAPI' in spite of imported Antispamsnippers SSL certificate (IExplorer - Options - Content - SSL - Import certificate).

Check your options tab.


i just read this reply. ok, i try this tonite. glad you posted this, we'll see

i tried that recommendation that worked. and i upgraded to 3.3.2.1 too. thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    antispamsniper.com Forum Index -> AntispamSniper for TheBat! All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group